Требования к хостингу для WordPress

Довольно часто в последнее время, люди задают похожие вопросы, все они примерно одинаковой тематики, люди интересуются что должно быть на сервере для запуска WordPress блога.

Вопросы бывают разные, вот некоторые из них:

  • Сколько места нужно для работы WordPress
  • Какой сервер нужен для WordPress
  • Какие требования к программному обеспечению установленному на сервере
  • Нужно ли PHP для WordPress
  • Нужна ли работа с MySQL для WordPress
  • Какие модули Apache должны быть установлены

Я постараюсь ответить на все эти вопросы этим постом.

Для работы WordPress достаточно 100Мб дискового пространства на сервере хостера, если вы публикуете подкасты или видеокасты, возможно понадобится больше. Практически у всех хостеров, нет пакетов хостинга с дисковым пространством менее 100Мб, поэтому в нынешнее время проблем с местом на сервере быть не может.

Наверняка все слышали о том, что WordPress очень требовательный к ресурсам сервера, но если ваш блог имеет менее 1000 посетителей в сутки, об этой проблеме вы можете даже не беспокоиться. А если ваш блог посещает более 1000 человек, имеет смысл задуматься о покупке виртуального сервера, для хостинга вашего блога. Также будет полезно ознакомиться с постами про оптимизацию производительности WordPress блогов.

Как правило WordPress блоги, хостятся на Unix серверах, с установленным WEB-сервером Apache, могут быть варианты и с Windows хостингом, но сам Apache изначально разрабатывался под Unix, поэтому желательно покупать хостинг который работает под Unix.

WordPress целиком и полностью написан на PHP, поэтому на хостинге без поддержки PHP, вы не сможете запустить WordPress блог. Встречаются разработки движков для блогов написанные на языке программирования Perl, но мы ведь в данном случае говорим о WordPress, поэтому поддержка PHP обязательна.

Практически все данные в WordPress блоге, сохраняются в базе данных MySQL, поэтому это второе обязательное требование, при выборе хостера для вашего блога. Желательно что бы и PHP и MySQL были выше 4-й версии, хотя в нынешнее время практически все нормальные хостеры постоянно следят за обновлениями серверного ПО, поэтому с этим проблем быть не должно.

Для удобства работы WordPress, необходимы модули к WEB-серверу Apache, поэтому желательно уточнить у хостера поддерживают ли их сервера модуль mod_rewrite (это тот модуль который обеспечивает работоспособность красивых ссылок) а также работу с SSL протоколом, это необходимо для некоторых плагинов по безопасности и статистике. Вообще чем больше различных модулей и возможностей предоставляет вам хостер, тем лучше для вас, главное что бы это не вредило производительности сервера.

Если вы не знаете как уточнить все эти моменты у вашего хостера, просто скопируйте следующие строчки:

Здравствуйте,

Я хочу установить на своем аккаунте отличный движок для ведения блогов — WordPress. Я хотел бы уточнить, соответствует ли мой аккаунт следующим требованиям:

PHP 4.3 или выше
MySQL 4.0 или выше
модуль Apache mod_rewrite

Спасибо!

Если вы совсем не хотите заморачивать себе голову всеми этими сложностями, воспользуйтесь услугами для блоггеров которые предоставляю я, либо обратитесь к компании Эскхостинг, которая предоставляет лучший хостинг для блогов, с установленным WordPress движком.

Если после этого поста у вас, остались какие-то вопросы, буду рад услышать их в комментариях.

Блоговодство:

Напишите свой комментарий